WordPress 2.6.3 Released, Fixes A Vulnerability in Snoopy

The WordPress team has released WordPress 2.6.3 which fixes a vulnerability found in Snoopy, a popular library to communicate with http and https protocols from PHP.

The vulnerability is low risk, however it is better to upgrade to the latest version. However the upgrade includes changes to only two files, which you can easily download and upload to your FTP site.

Download the files below, to upgrade to WordPress 2.6.3.

  1. wp-includes/class-snoopy.php
  2. wp-includes/version.php

Important Note: Only upload the files if you using the WordPress version 2.6.2 currently, if you are using a earlier version, perform a full upgrade to WordPress 2.6.3.

3 thoughts on “WordPress 2.6.3 Released, Fixes A Vulnerability in Snoopy”

  1. If you don’t want to download the whole release to get the security fix, you can download the following two files and copy them over your 2.6.2 installation.

    1. wp-includes/class-snoopy.php
    2. wp-includes/version.php

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>