Spirit Jailbreak Application Updated To Support iTunes 9.2
By on June 27th, 2010

The Spirit jailbreak application has been updated to support iTunes 9.2. Other than support for iTunes 9.2, no new features have been added. The Spirit application is one of the easiest way to jailbreak your iPhone/iPodios4_logo Touch or the iPad. Sadly, the Spirit application still does not support iOS4 and/or iPhone 4.

Currently, the Spirit application supports iOS 3.1.3 and 3.1.2 for iPhone 3GS, 3G, and the iPhone 2G. All version of iPod Touch are supported as well. For the iPad, iOS 3.2 is supported. Users who want to jailbreak their iPhone 3GS/3G or iPod Touch running on iOS4 can use either sn0wbreeze or PwnageTool 4.0. On a personal note, I would suggest iPhone 3G owners not to upgrade to iOS 4.

The iPhone 3G does not have enough horsepower to run iOS4 properly. If by chance, you have already updated your iPhone 3G to iOS 4 and want to go back to iOS 3.1.3, follow this guide.

(Source)

Tags: , , , , , , , , ,
Author: Rajesh Pandey Google Profile for Rajesh Pandey
Rajesh is a 19 year old nerd, currently pursuing B.Com Hons from Bhawanipore college in Kolkata, India. He loves everything tech, especially Android. You can follow him on twitter @ePandu or mail to him at rajesh@techie-buzz.com.

Rajesh Pandey has written and can be contacted at rajesh@techie-buzz.com.
  • Jeff

    Any support for IPOD Touch 2G MC Model in the near future for IOS4?

    • Btdubsguy

      Sadly, it would not appear so. It has become clear that redsn0w has forsaken us, so I would say that your best option is to downgrade to 3.1.3 and let the magic fly with Spirit. Honestly, it doesn't seem like a bad idea at this point. The jailbreak has almost all of the features of iOS4 on the iPod Touch, including mulitfl0w, which was left out as multitasking anyway. So really, 4.0 is NOT all that it is cracked up to be on the 4.0 train =0. You really aren't missing much by sticking with 3.1.3 or 3.1.2

      • Callum

        jailbreakme apparently supports 4.0 and if u have used that does it sync with itunes 9.2?

  • Roger

    " Users who want to jailbreak their iPhone 3GS/3G or iPod Touch running on iOS4 can use either sn0wbreeze or PwnageTool 4.0. "

    NOT TRUE! Only people on 3.1.2 can jailbreak with these tools. These tools are not for every 3GS. 3.1.3 can be done only if you are able to downgrade to 3.1.2

    • http://www.lifeofrajesh.com Rajesh Pandey

      Do check the hyperlinks. I have already mentioned that in the sn0wbreeze and Pwnage Tool post.

  • Gary

    where can i find the sprirt jailbreak for itunes 9.2?

    • Biver

      I found a file for windows called Spirit.Fix.iTunes.9.2.rar that appeared to be what's being talked about, but I just got a bad feeling about it so I'm not posting a link to it. Plus, isn't weird that comex doesn't mention it at ALL on his site?

      • Btdubsguy

        I agree. I think im going to have to do some more poking around before I go through with the jailbreak.

  • Moxave

    Any release date for the spirit iOS 4.0 jailbreak?

    • http://keithdsouza.com Keith Dsouza

      @Moxave – Unfortunately there is no fixed release date yet.

      • Btdubsguy

        Comex said that the release date is "when it comes out" which i would say is once he fixes the exploit used in 4.0 to run with 4.0.1 and 4.1. Keep in mind that these people have a life, and need time to sort out their own personal affairs before anything else happens with the jailbreak.

 
Copyright 2006-2012 Techie Buzz. All Rights Reserved. Our content may not be reproduced on other websites. Content Delivery by MaxCDN