Patches for Several Firefox Security Vulnerabilities Appear in Launchpad
By on January 8th, 2012

A few days ago, several medium and low priority security-related bugs were handled for Firefox and many other Mozilla applications. These bugs affected all versions of Firefox from version 4, and all versions of Thunderbird from version 5. All patches for all these bugs were added to Launchpad.

While some of these attacks caused the application to crash, others would allow execution of arbitrary code through JavaScript. As Ubuntu’s LTS releases are supported for long periods, fixes for these bugs were released for Ubuntu 8.04, and also for Ubuntu 10.04, Ubuntu 10.10, Ubuntu 11.04 and Ubuntu 11.10.

The Ubuntu Security Notice on this page lists down all the vulnerabilities that were addressed with updated Launchpad patches.

Alexandre Poirot, Chris Blizzard, Kyle Huey, Scoobidiver, Christian Holler,
David Baron, Gary Kwong, Jim Blandy, Bob Clary, Jesse Ruderman, Marcia
Knous, and Rober Longson discovered several memory safety issues, which
could possibly be exploited to crash Firefox or execute arbitrary code as
the user that invoked Firefox. (CVE-2011-3660)

Aki Helin discovered a crash in the YARR regular expression library that
could be triggered by JavaScript in web content. (CVE-2011-3661)

It was discovered that a flaw in the Mozilla SVG implementation could
result in an out-of-bounds memory access if SVG elements were removed
during a DOMAttrModified event handler. An attacker could potentially
exploit this vulnerability to crash Firefox. (CVE-2011-3658)

Mario Heiderich discovered it was possible to use SVG animation accessKey
events to detect key strokes even when JavaScript was disabled. A malicious
web page could potentially exploit this to trick a user into interacting
with a prompt thinking it came from the browser in a context where the user
believed scripting was disabled. (CVE-2011-3663)

It was discovered that it was possible to crash Firefox when scaling an OGG
<video> element to extreme sizes. (CVE-2011-3665)

You can find more about these vulnerabilities in the Ubuntu CVE tracker with the numbers 3658, 3660, 3661, 3663 and 3665. For Ubuntu 11.10 users, a Firefox 9 patch is available at this link. Alternatively, you can update your system with the latest version of all packages. Once the update is done, do not forget to restart Firefox, to apply the patch.

Tags: ,
Author: Chinmoy Kanjilal Google Profile for Chinmoy Kanjilal
Chinmoy Kanjilal is a FOSS enthusiast and evangelist. He is passionate about Android. Security exploits turn him on and he loves to tinker with computer networks. He rants occasionally at Techarraz.com. You can connect with him on Twitter @ckandroid.

Chinmoy Kanjilal has written and can be contacted at chinmoy@techie-buzz.com.
 
Copyright 2006-2012 Techie Buzz. All Rights Reserved. Our content may not be reproduced on other websites. Content Delivery by MaxCDN